葡萄城吉流帮助和使用方法

Back Forward Home Print
葡萄城吉流(FlowMan)
帮助和使用方法

内容

管理和配置
工作流设计器
工作流与SharePoint的交互
流程节点


管理和配置

葡萄城吉流(FlowMan)
管理和配置

关于“管理和配置”的主题
11 项

Help and How-to
许可证

Help and How-to
数据库设置

Help and How-to
管理内容数据库

Help and How-to
Web应用激活设置

Help and How-to
管理工作流节点

Help and How-to
全局设置

Help and How-to
管理电子邮件审批

Help and How-to
消息模板

Help and How-to
激活葡萄城吉流（FlowMan）

Help and How-to
配置用户设定

Help and How-to
安全设定

Help and How-to
工作流库

Help and How-to
用户管理


许可证

许可证

可以在Server Farm层导入许可证，验证许可证并决定当前版本和对应的功能。

您可以多次导入许可证文件，以最后一次导入的为准。


数据库设置

数据库设置

您可以在管理中心页面中看到“数据库设置”链接，点击进入。

Central administration menu

此设置必须在已经完成许可证文件导入后才能进行，并且优先于其他设置。

The database settings page

配置数据库

The configuration database form

每个葡萄城吉流（FlowMan）安装都需要在指定的服务器上配置数据库。

有两种方式可以选择，一种是由葡萄城吉流（FlowMan）创建一个新的数据库，或者选择“连接现有的数据库”来使用一个现有的数据库。

内容数据库

The new content database form

工作流运行需要内容数据库，葡萄城吉流（FlowMan）至少需要配置一个内容数据库。


管理内容数据库

葡萄城吉流（FlowMan） 平台可支持多个内容数据库，针对每个网站集上的相关工作流数据可以使用一个内容数据库。

查看内容数据库

此页面用于确定为指定网站集存储数据的工作流内容数据库，页面列出了所有网站集及其相应的数据库。

管理内容数据库

管理数据库映射页面可以在一个新网站集激活网站集功能时选择工作流内容数据库。这是针对每一个SharePoint内容数据库的，所以在一个指定的SharePoint内容数据库中所有SharePoint网站集都使用指定的工作流内容数据库。已经激活的网站集将不受这些设置更改的影响。


Web应用激活

Web应用激活

“Web应用激活”需要在已经成功导入许可证文件后并且已经完成配置内容数据库后来进行。

Central administration menu

在下拉框中选择您需要激活的Web应用，然后点击“激活”按钮。


全局设置

全局设置

全局设置页面用来设定葡萄城吉流（FlowMan） 在网站Farm中所有网站的邮件设置。您可以管理中心中进入。在全局设置前您必须已经配置完许可证和数据库还有已经激活Web应用。

Central administration menu

选项

电子邮件发送服务器设定

设置葡萄城吉流（FlowMan）用来发送邮件的邮件服务器。请确定SharePoint应用池有权限使用此服务器。

发送邮件地址

设置葡萄城吉流（FlowMan）用来发送邮件通知的地址。

回复邮件地址

设置葡萄城吉流（FlowMan）发出的邮件通知的回复地址。

现在您可以在网站集中激活葡萄城吉流（FlowMan）。


管理流程节点

管理流程节点

此页面可以管理供设计器使用的葡萄城吉流（FlowMan）流程节点。

在网站上点击“网站设置”进入“管理流程节点”页面对网站级别的流程节点进行管理，您也可以在管理中心中对网站集级别的流程节点进行管理。

把允许使用的流程节点勾选上，点击“确定”按钮


激活葡萄城吉流（FlowMan）

激活葡萄城吉流（FlowMan）

为了使用葡萄城吉流（FlowMan）产品来设计工作流，需要在每一个使用此功能的网站激活葡萄城吉流（FlowMan）。

首先为网站集激活产品，然后需要激活各网站的功能。

为网站集激活 葡萄城吉流（FlowMan） 产品

在顶级网站首页上点击“网站操作”然后点击“网站设置”：

在右面一列， “网站集管理”中，点击 “网站功能”：

点击 葡萄城吉流（FlowMan）网站功能后的 “激活”按钮。

等待一会后， 网页会刷新并且状态变成 “活动”

现在可以在各个网站中激活葡萄城吉流（FlowMan） 功能。

在网站中激活葡萄城吉流（FlowMan）

在指定网站首页上点击 “网站操作”，然后点击“网站设置”：

在右边一列， “网站管理”中，点击 “网站功能”.

点击 葡萄城吉流（FlowMan）网站功能后的“激活”按钮。

等待一会后， 网页会刷新并且状态变成 “活动”


工作流库

工作流库

工作流中心页面显示所有您在此网站中创建的工作流。

您点击“网站设置”，在GrapeCity FlowMan组下可以看到“工作流中心”。

在工作流中心页面中您可以查看所有此网站中已经发布的工作流。工作流名称下包括描述信息，最后编辑用户，最后编辑时间和此工作流所在列表名称。

点击工作流名称就可以进入图形化的流程查看页面，显示的流程不能编辑。


消息模板

此页面用来设定“要求审批”流程节点中邮件的模板，您可以在管理中心中对整个Farm下的网站集统一设定，也可以在每个网站自己的网站设置中单独设定。

消息模板

消息模板中的内容将会作为“要求审批”，“要求审阅”，“收集数据”流程节点中通知邮件内容的标准页眉和页脚

默认的邮件模板内容为富文本形式。您可以添加您认为适合的内容作为模板。

请注意：更改的内容仅对后面新建的工作流生效。

工作流错误或取消通知设定

可以设定当工作流失败或取消时需要受到邮件通知的用户。


用户管理

用户管理

此页面对组织结构，用户角色进行设定，方便在工作流中选取各种类型的用户。

您可以在管理中心通过点击“管理组织结构”页面进入。

您可以在页面左边的导航栏中看到一共有8个分类可供设置

用户信息

?

管理组织结构中所有用户信息，您可以在表单中输入一个新用户，并把此用户与一个已有的域账号相关联。

输入用户的姓名，显示名称，直属经理等基础信息。

建立一个用户前必须先设定一个用户类型。

角色

管理组织结构需要用到的所有角色。

部门用户

管理部门和用户的关联。

根据用户的访问权限，树形显示相应部门的组织结构,点击部门在页面右方显示部门下所属的用户信息。

用户可以属于一个或多个部门，在每个部门中可以有不同的职务。

每个用户可以设定一个默认部门。

每个部门可以设定一个或多个用户为部门经理。

组织结构

管理部门基本信息。

管理部门从属关系的树状结构。

建立一个部门前需先设定一个部门类型。

部门中的角色与用户

管理部门和角色和用户的关联。

一个角色可以在多个部门中出现，并关联到属于该部门的用户。

部门类型

管理部门类型列表。

用户类型

管理用户类型列表

职务

管理职务列表。


安全设定

安全设定

根据用户如使用葡萄城吉流（FlowMan）的不同需求，有不同的安全设定。下表列出了各种操作需要的最小权限。 在一般情况下，以网站为基础进行网站级别的权限集中管理，即在统一页面中对本网站的角色设置、用户权限分配进行管理。运行时的权限可以从该网站或父网站继承，但必须在列表级给于用户有效权限。

The 钁¤悇鍩庡悏娴侊紙FlowMan锛?site settings table

管理工作流设计

要添加一个用户（组）到工作流设计者组中，您必须有网站管理员的权限。

您可以在“网站设置”中点击“管理工作流设计者”

The 钁¤悇鍩庡悏娴侊紙FlowMan锛?site settings menu

在此页面中您可以中添加，删除工作流设计者。请确认设置权限的用户必须有完全访问权限。


工作流库

工作流库

工作流中心页面显示所有您在此网站中创建的工作流。

您点击“网站设置”，在葡萄城吉流（FlowMan）组下可以看到“工作流中心”。

在工作流中心页面中您可以查看所有此网站中已经发布的工作流。工作流名称下包括描述信息，最后编辑用户，最后编辑时间和此工作流所在列表名称。

点击工作流名称就可以进入图形化的流程查看页面，显示的流程不能编辑。


电子邮件审批设置

电子邮件审批设置

此页面用于管理葡萄城吉流（FlowMan）的邮件审批功能中用到的关键字。更多信息请查看 邮件审批。

要使用邮件审批功能必须现在管理中心激活它。您在管理中心葡萄城吉流（FlowMan）组下可以看到“管理邮件审批设置”

如果您看到“在SharePoint上没有接收邮件服务器”请根据SharePoint配置文档来配置。

如果您都配置完毕后，会看到“激活邮件审批”的选项。

选择“激活”，您需要输入一个用来发送、回复邮件的邮件地址，最后点击“保存”。

页面上列出可以被邮件审批功能识别的关键字列表，您可以添加、编辑、删除这些关键字。

您可以点击“创建新关键字”链接来新建一个关键字，或者点击已存在关键字的名称进入编辑页面。关键字最大允许长度为255。

您还可以管理可被忽略的短语列表。


配置用户设定

配置用户设定

用户设定可以分别设定在工作时间和非工作时间，首选的信息通知方式。包括：电子邮件，LCS/OCS及手机短信3种方式。并设定手机号码和发送手机短信息需要的域名信息。


工作流设计器

葡萄城吉流(FlowMan)
工作流设计器

关于“工作流设计器”的主题
13 项

Help and How-to
工作流设计器使用入门

Help and How-to
管理工作流

Help and How-to
打开和保存工作流

Help and How-to
导入和导出工作流

Help and How-to
发布工作流

Help and How-to
动态引用

Help and How-to
内容选取器

Help and How-to
工作流启动数据

Help and How-to
工作流启动选项

Help and How-to
工作流常量

Help and How-to
工作流变量

Help and How-to
错误处理


工作流设计器入门

工作流设计器入门

创建新工作流

有两种方式可以创建一个新工作流。首先，您可以在列表或文档库中点击“设置”菜单项，再点击“工作流设计器”菜单项。

或者您点击“管理工作流”菜单项，打开“工作流中心”页面，并点击页面上方的“新建”按钮，创建新的工作流。

设计器画面

工具栏

在设计器画面中，您会看到：左侧为工具栏，包含所有流程节点，并按照流程节点的特性进行分类存放，分类目前包含：

  • 人机交互
  • SharePoint操作
  • 流程操作
  • 流程逻辑

配置流程图

设计器的右侧下方主要部分为流程设计画板，在画板上可以添加流程节点，对之进行配置形成流程定义；默认起始设计阶段画板上放置“开始”和“结束”2个流程节点

在设计画板上添加流程节点一共有三种方式

  1. 您可以直接从工具栏中拖拽出流程节点到画板的流程图线上
  2. 您可以在流程图线上点击右键，选择需要的流程节点添加

  3. 您可以先在设计画板上选中流程图线，然后双击工具栏中需要添加的流程节点

配置流程节点

需要配置此流程节点，您可以单击设计画板上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”菜单项来打开配置页面。

您可以在流程画板上用鼠标移动流程节点到其他流程图线上，若同时按住Ctrl键则为复制操作。

您把鼠标放置于流程节点的图形图标上时，会有浮动窗口出现，如果此流程节点配置不完全，则浮动窗口显示为黄色，并且有需配置信息提示。如果此流程节点配置完全，则浮动窗口显示为绿色，并且有已配置信息显示

流程节点的右键菜单有以下几项：

  • 配置：可以配置不同的选项使流程节点可以运行。
  • 编辑名称：可以使流程节点上的名称处于可编辑状态，您也可以直接单击流程节点的名称来编辑它。
  • 复制：您可以复制一个流程节点到其他流程图线上，它的名称和配置信息都将被复制。您也可以按住Ctrl键移动流程节点来实现复制功能。
  • 删除：此操作将把该流程节点从设计器画板上移除，您也可以直接点击流程节点上的删除按钮来删除。
  • 展开/收起：如果此节点包含子节点，则您可以使用此功能使子节点隐藏或显示，您也可以直接点击流程节点上的展开/收起按钮来操作。

流程图线上的右键菜单有以下几项：

  • 粘贴：当有一个流程节点做了复制操作，则流程图线的右键菜单此选项可选，点击后流程节点被粘贴在此流程图线上。
  • 流程节点：您可以添加所需的流程节点。

操作按钮

右侧上方为流程设计画面功能菜单：操作和设置。

  • 新建： 新建一个工作流且不保存当前已经设计的流程，所以当您点击“新建”后，系统会询问是否确认新建，按“是”则会丢失已经设计的内容创建一个空白的新流程，按“否”则不作任何操作。
  • 打开： 请查看 打开和保存工作流 。
  • 保存： 请查看 打开和保存工作流。
  • 发布： 请查看 发布工作流 。

设置按钮

工作流设置

其中包含以下几项：

  • 工作流名称和描述： 请查看 工作流名称和描述。
  • 工作流启动参数：请查看 工作流启动参数。
  • 工作流启动数据： 请查看工作流启动数据 。
  • 工作流变量： 请查看 工作流变量。


打开和保存工作流

打开和保存工作流

此章节会描述怎样打开和保存一个工作流。关于工作流的发布您可以查看发布。

打开一个工作流

有两种方式可以打开一个已经存在的工作流：

您可以先创建新工作流。点击“打开”菜单项。

此时会弹出一个窗口，其中包含了所有已发布或未发布已保存的工作流，您可以选择其中之一，点击“打开”按钮。

另一种方式是在SharePoint列表或文档库中点击“管理工作流”菜单项

打开的页面中包含了所有已发布或未发布已保存的工作流，您直接点击您需要的工作流就能打开它。

保存工作流

针对在工作流设计器中进行设计的工作流程，您点击“保存”菜单项可以随时进行保存。你可以使用快捷键Ctrl+S来实现此功能。

如果您没有在工作流名称中事先输入一个名称，则在第一次保存时会弹出窗口让用户输入流程名称，默认名称为【新工作流】；保存完毕后显示保存成功信息。同一个列表下流程名称不可重复。


标题和描述

标题和描述

每一个工作流都需要设定名称。

您可以工作流设计器画面中点击打开菜单项“工作流设置”。

在打开的窗口中点击“工作流名称和描述”标签。

选项

名称

输入工作流名称，同一列表下的工作流名称不能重复。

描述

输入此工作流的描述信息。

如果您没有在这里设定工作流名称而直接保存或发布，系统都会有窗口弹出让您输入。


导入和导出工作流

导入和导出工作流

导入和导出工作流程功能，可以帮助您把已经设计好的流程转移到其他列表中，从而提高工作流效率。

导出工作流

每一个工作流程都可以被导出为一个后缀名为"gwf"的文件。要导出工作流，您首先在工作流设计器页面中点击“操作”按钮，在菜单项中点击“导出”。

您将会被提示有文件可以下载，文件名为系统随机产生，您可以修改成容易识别的。选择一个文件存放路径后点击“保存”按钮。

导入工作流

要导入工作流，您首先需要新建一个工作流，有两种方式可以新建。首先打开一个列表然后点击“设置”按钮，然后：

  1. 选择“创建工作流”菜单项。系统将打开工作流设计器页面。
    2
  2. 选择“管理工作流”菜单项。在工作流中心页面中点击“创建”按钮，系统将打开工作流设计器页面。W
    1

    3

现在点击“操作”按钮，然后点击“从文件导入”菜单项。

选择需要导入的文件后，点击“导入”按钮。

请注意：只有通过葡萄城吉流（FlowMan）导出功能生成的文件才能被导入。

先前设计的工作流，它所有的配置信息都将被加载，但因为列表的变更可能有配置项无法生效，您可以重新配置这些流程节点。


发布工作流

发布工作流

流程设计完毕后，应先发布然后才能运行。发布时应先判断流程是否已经保存，如未保存则自动保存后再发布。

发布一个工作流

您在流程设计完毕后需要点击“发布”菜单项。您可以使用快捷键Shift+P来实现此功能。

The publish option in the Actions menu

系统会验证工作流是否有效，在发布过程中您会看到等待图标 [image] ，请稍作等候。

如果发布成功，则系统会有“发布成功”的提示

如果工作流中有错误，包括流程节点没有配置，则发布不成功。

可以发布工作流的用户权限，请查看安全设置。

当工作流发布成功后，您可以在管理工作流页面中看到。


启动数据

启动数据

使用此页面可以设定在流程启动时需要用户输入的数据，其运作方式类似于工作流变量，可以被流程节点引用。

工作流启动数据类型包括：

  • 单行文本
  • 数字
  • 多行文本
  • 日期时间
  • 布尔型（是/否）
  • 选择
  • 用户或组

    • 您可以工作流设计器画面中点击打开菜单项“工作流设置”

    在打开的窗口中点击“工作流启动数据”标签

    选项

    名称

    输入启动数据的名称，

    数据类型

    选择一个数据类型。

    必须

    如果选择了“必须”，则在流程启动时，必须对此数据进行设定，否则无法启动工作流。

    默认值

    输入默认值，在流程启动时，此数据默认显示此值

    填写完必要的数据后，点击“添加”按钮，会在数据列表中新增一行。

    如果您需要更改启动数据，则直接点击它在数据列表中的行，此数据所属值自动显示在输入框中，更改后点击“保存”按钮，完成修改。

    如果您需要删除启动数据，则直接点击它所在数据列表行后的“删除”按钮。


启动选项

启动选项

工作流启动参数可以决定工作流启动的方式。

您可以工作流设计器画面中点击打开菜单项“工作流设置”

在打开的窗口中点击“工作流启动参数”标签

选项

手动启动

对关联列表中的任意项目手工启动该流程。

新建项目后自动启动

在创建项目时自动启动该流程。

编辑项目后自动启动

在编辑项目后自动启动该流程。在任何时候签入一个项目都不会触发工作流。

启动时选择用户部门

选择此项，则在工作流启动时，需要您选择用户部门，

任务列表

为该工作流中发生的人机交互任务选择一个SharePoint任务列表，默认为Workflow Tasks。


工作流变量

工作流变量

工作流变量可以为工作流创建多种类型的工作流变量，工作流变量可以在流程设计过程中引用。变量类型包括：

  • 文本
  • 数字
  • 列表项目ID
  • 日期时间
  • 布尔型（是/否）
  • 流程节点ID
  • 集合类型

设置变量

您可以工作流设计器画面中点击打开菜单项“工作流设置”

在打开的窗口中点击“工作流变量”标签

点击页面上的“增加”按钮，则在变量列表中会新增空白行，您在该行上单击“变量名”即可输入变量的名称，单击“变量类型”则有下拉框供您选择类型。

如果您需要更改变量则直接单击变量列表中您需更改的变量行。

如果您需要删除变量，则直接点击此变量行后的“删除”按钮。

请注意：正在被使用的工作流变量不能被删除。


工作流常量

工作流常量

工作流常量可以在Server Farm，网站集和网站层面分别设定。可以通过动态引用 在流程定义中引用在各个层面设定的工作流常量。

当设计者在工作流中使用一个常量，他们不需要知道常量中确实保存的是实际值，常量适用于存放URL地址等。

您可以点击“网站设置”下的“管理工作流常量”来新建一个常量。

选项

常量名称

输入常量名称，它会在动态引用中使用到。

类型

工作流常量的类型有：字符串、数字、日期、证书（用户名和密码）。

值

在工作流运行时，会把此值替换之使用。

描述

关于常量额外的描述信息

敏感

工作流常量可以置为“敏感”类型，从而加密保存。某些流程节点中可以引用“敏感”类型的工作流常量。

敏感类型和证书类型的工作流常量都以加密形式保存在数据库中。


动态引用

动态引用

在工作流程节点设计过程中可以使用动态引用，根据包含了列表信息和工作流实例相关的工作流上下文环境信息创建文本或生成超链接。

动态引用中可以包含如下几部分信息：

  • 通用类：和当前流程相关的上下文信息。
  • 列表元数据：和当前流程相关的SharePoint列表元数据。
  • 工作流常量和变量：当前网站配置的工作流常量和当前工作流配置的工作流变量。

利用动态引用创建超链接如下图：

The Hyperlink Insert Reference

您要创建一个超链接必须选择“您从这个数据创建超链接”选项，则会有超链接文本和地址的输入框供您填写。您在选择框中选择需要的超链接显示名或地址， 点击第一个“添加”按钮，则相应的动态引用即会加入到您当前鼠标激活的文本框中。当您超链接的显示名称和地址都已设置完毕后，点击第二个“添加”按钮， 则动态引用被添加至正文中。

动态引用里包含的信息具体说明如下：

  • 所有审批人的评论：所有参与审批的人员在审批过程中写的评论，以审批人员姓名 + 帐号 + 审批时间 + 评论文字 + “换行符” + 下一个审批人员相关信息。
  • 审批人的评论：最近一次审批动作中所有审批人员作出的评论。
  • 当天日期：当天日期
  • 当时时间：当时时间
  • 文档是否可写：如果当前工作流相关的存储在文档库里的文档处于可编辑状态，则返回“是”；否则返回“否”；如果当前工作流相关的不是文档库而是普通列表，则一直返回“是”。
  • 项目链接：当前工作流相关的列表项目的链接。
  • 最后参与人帐号：最后一个参与当前工作流的审批、审阅等需要用户交互工作的人员帐号，“域名\用户名” 。
  • 最后参与人姓名：最后一个参与当前工作流的用户交互的人员姓名 。
  • 列表ID：当前工作流相关联的SharePoint列表ID
  • 列表名称：当前工作流相关联的SharePoint列表名
  • 网站名称：当前网站的名称
  • 网站链接：当前网站链接
  • 启动日期：工作流启动日期
  • 启动时间：工作流启动时间
  • 工作流实例ID：工作流实例ID
  • 工作流日志链接：文本形式展示当前工作流日志的链接
  • 工作流状态图链接：图形化形式展现当前当前工作流状态的链接
  • 工作流名称：工作流名称

>下列信息在创建“请求审批的通知”中可用：

  • 审批链接：审批者画面的链接，审批人员可以点击该链接进入SharePoint进行审批操作。
  • 审批人员姓名：当前需要进行审批操作的人员姓名
  • 审批通过：点击後就可以批准当前工作流的链接。可以用于用户自定义的审批界面中
  • 审批拒绝：点击後就可以拒绝当前工作流的链接。可以用于用户自定义的审批界面中
  • 代理设定链接：设定代理审批人员的链接，如果当前工作流任务允许设定代理的话


管理工作流

管理工作流

对于已经发布或未发布已保存的工作流，您可以通过点击列表或文档库中”操作“按钮下的”管理工作流“子菜单项。

The list settings menu with the manage workflows option

针对列表的工作流列表，按照“已发布”和“未发布”两种状态分类排列。 在工作流列表中，可以开始创建新的工作流，也可以点击已经存在的工作流开始修改，或是删除已经存在的工作流。

The manage workflows page

  • 创建新工作流： 点击页面上方的”创建“按钮 创建一个新工作流.
  • 编辑已经存在的工作流： 直接点击已经存在的工作流名称链接，打开它进行编辑。
  • 删除已经存在的工作流： 点击 Delete button 按钮来删除对应的工作流。

取消发布

对已经发布的工作流，如果需要将其状态转换成为未发布状态，则可以利用SharePoint内置的工作流设置功能，从列表设定的权限管理下的“工作流设置”进入。

The list settings page with the workflow settings link

点击“删除工作流”进入。

The workflow settings page

通过将工作流的状态从“允许”变更为“删除”，就可以将已经发布的流程状态置为“未发布”.

The workflow settings page


用户选取器

用户选取器

此功能主要是供用户在配置工作流程中的人机交互任务时选取人员，组织结构或角色。

您可以选取方式包括5种：

The condition form

?
  1. 内部搜索：从AD或SharePoint中搜索并选择用户或用户组
    2. ?
  2. 外部电子邮件地址：直接输入电子邮件地址

    3. The condition form

  3. 动态引用：您可以选择项目属性或工作流属性或者工作流变量值动态的生成用户信息。具体信息请查看动态引用。

    4. The condition form

  4. 角色选择：从组织结构信息的“角色”表中取得所有角色信息构成角色列表供用户选择。
    5. ?

    角色列表的第一行为“流程发起者”；第二行为“直线经理”；第三行为“部门经理”；第三第四行开始是角色表中取得的所有角色名称，按名称排序。

    如果选择的是流程发起者，则直接对应流程的发起者（Initiator）。

    如果流程发起者的AD帐号在用户表中不存在，在日志中项目：“流程发起者（AD帐号）在组织结构的用户列表中没有登记，无法解析直线经理对应的用户”。

    The condition form

  5. 组织结构选择
    6. ?

    从部门、部门用户、部门角色用户表中取得包含部门、部门内角色以及部门内用户的信息；并构成树状结构。

    您可以直接从组织结构图中选择相应的用户。

    用户，组织结构，角色的设置请查看组织结构。


内容选取器

内容选取器

葡萄城吉流（FlowMan）可以使用内容选取器帮助流程设计者在运行时设定值。

内容选取器设定的值包括3个来源：

当前项目

选择此项，您可以设置当前项目的字段，则工作流运行时将从当前项目的指定字段中选取值。

工作流变量

选择此项，您可以设置工作流变量和启动数据，在工作流运行时工作流变量会不停的变化。

其他列表值

在内容选取器中可以引用并返回当前网站中的任意列表中的项目的元数据，您可以通过对列表设置过滤条件确定内容选取器返回的具体项目字段。

过滤条件的值可以多级选定，最大为3级。


错误处理

错误处理

在一些流程节点中有“错误处理”的设置，它用于部分流程节点捕获运行时错误，并根据预先设定的逻辑对错误进行处理。

The error hanlding panel

选项

捕获错误

确定是否捕获工作流运行过程中发生的错误；选择是，则在运行中发生错误时，按照下面的设定对错误进行处理，而不会导致流程停止运行。

您也可指定一个布尔型的工作流变量来确定是否捕获错误。

保存错误原因

指定一个工作流变量保存当前节点发生错误的状态；如果当前节点在运行过程中发生了错误，则该变量值被设定为是，否则为否

保存错误内容

指定一个文本类型的工作流变量保存当前节点发生错误的内容


工作流与SharePoint的交互

葡萄城吉流(FlowMan>
工作流与SharePoint的交互

关于“工作流与SharePoint的交互”的主题
9 项

Help and How-to
启动工作流

Help and How-to
同意，拒绝，审阅记录

Help and How-to
设置工作流任务代理

Help and How-to
查看工作流历史

Help and How-to
查看工作流状态

Help and How-to
我启动的工作流Web控件

Help and How-to
我的工作流任务Web控件

Help and How-to
工作流计划

Help and How-to
关于电子邮件审批


启动工作流

启动工作流

根据工作流设置中工作流“启动参数”，有三种方式可以启动工作流。更多信息请查看启动选项。

如果是手动启动，则用户可以在列表或文档库中，选择需要启动工作流的项目，在下拉框中选择“工作流”

“启动新工作流”页面中列出所有该列中已经发布并且不在运行状态中的工作流。

选择一个需要启动的工作流后，您在填入必须输入的启动数据后，点击“启动”按钮

启动完毕后，页面将返回到列表或文档库页面，在项目行后有所有运行过的工作流列，列出当前该工作流的运行状态。


同意，拒绝，审阅记录

同意，拒绝，审阅记录

在运行时，当有工作流任务被创建，任务会分配给指定用户且有通知信息发送。用户可随时通过我的工作流任务 Web控件 或者网站中的葡萄城吉流（FlowMan）任务列表来查看。

要处理一个任务，请点击通知邮件中此任务的超链接（指定给您并且您有权限）或者我的工作流任务Web控件。 这样会打开“同意拒绝”页面来填写反馈

“同意拒绝”页面部分

状态

当任务是由“请求审批”流程节点生成时，用户可以选择同意或拒绝。您作出的选择可能会因此决定后面工作流路径的走向。 当在“请求审批”流程节点中选择了“允许前加签”，“允许后加签”，“允许添加审批人”的选项，则在此页面会有相应的选项列出 您需要指定前加签的用户，则必须先选中“前加签”然后在下面的人员选择框中选择相应的人员，如果您需要指定后加签或者添加审批人，则直接在人员选择框中添加人员

当任务是由“请求审阅”流程节点生成时，工作流的走向不会因为您作出的选择而发生变化。

根据流程节点的配置情况，用户可以把任务委派给其他用户。

注释

使用此字段可输入任务关于此任务被同意或拒绝的理由。

项目属性

列出和此项目有关的属性。为了查看完整的项目信息可点击“项目”右边的标题名称。 同样，要查看工作流图形状态，可点击“查看”。

其余列出的是自定义列（包括未显示在这个屏幕上） 。您可以通过建立“工作流任务视图”来确定哪些字段需要显示。视图的名称在SharePoint管理中心的全局设置中进行配置。


工作流历史

工作流历史

此页面可以看到工作流运行详细信息。

要看到工作流运行的历史详细信息，您需要在列表或文档库中点击项目，在下拉框中选择“查看工作流状态”菜单项。

在工作流状态页面中显示和当前项目关联的所有流程的状态信息，流程分为“运行中”，“已经结束”，“发生错误”，“已经取消”四类。

点击任意流程的标题进入图形化状态页面。可能会因为多次重复运行同一流程造成有重复的流程名称存在，请根据启动时间来选择您需要查看的流程。

流程摘要信息会在画面的左上角显示，您点击“查看详细情况”，进入工作流历史详细信息显示页面

工作流历史详细信息共分三个部分：

  • 流程节点历史： 在工作流中完成的节点名称，开始、结束时间和持续时间。
  • 任务历史： 在工作流中产生的人机交互任务，包括审批、审阅、收集数据等；具体信息包含：用户名，任务分配时间，任务完成时间，审批结果，评论。
  • 工作流信息： 显示流程节点产生的信息，也包括审批、审阅用户输入的评论，以及利用“项目工作流日志”节点写的日志信息。

您可以点击页面上部的“查看图形视图”按钮，回到图形化工作流状态页面。


工作流状态

工作流状态

此页面可以看到工作流运行状态。

要看到工作流状态，您需要在列表或文档库中点击项目，在下拉框中选择“查看工作流状态”菜单项。

在工作流状态页面中显示和当前项目关联的所有流程的状态信息，流程分为4类：

  • 运行中
  • 已经结束
  • 发生错误
  • 已经取消

信息包含：

  • 流程名称
  • 启动者姓名
  • 启动时间
  • 空闲时间

点击任意流程的标题进入图形化状态页面。可能会因为多次重复运行同一流程造成有重复的流程名称存在，请根据启动时间来选择您需要查看的流程。

流程摘要信息会在画面的左上角显示，它包含“列表项目名”，“流程名”，“发起者”，“启动时间”，“目前状态”并且可以链接到详细信息。更多信息请查看工作流历史。

工作流程的图形化监控见面上显示的流程节点和节点之间的关系和相应工作流程的设计画面完全一致，并以不同颜色表示节点的状态：

  • 橙色，代表流程当前运行中的节点
    • ?
  • 绿色，代表已经完成的节点
    • ?
  • 灰色，代表该节点还没有运行到，或是在当前流程中不会被运行


设置工作流任务代理

设置工作流任务代理

审批或审阅等人机交互任务，可以由接到任务的用户分派给其他用户完成。您可以点击 同意或拒绝 任务页面上的“委派”链接。

指定任务分派

这个必填字段指定任务分派的用户，您可以点击用户、组织结构、角色选择器来选择用户。

注释

您可以在这里输入给新审批人员的注释，此信息内容会加在“需要审批通知”中发送给新审批人员。

长期任务分派

每一个工作流用户都可以把自己的任务派发给其他用户。建立自己的用户设定，就会在指定时间里把所有分配给自己任务全部转发给指定用户。请点击页面上部自己的登录名，在打开的下拉菜单中选择“葡萄城吉流（FlowMan）”，然后在子菜单中选择“用户设定（任务代理）”。

选项

开始日期

代理开始的时间。

结束时间

代理结束的时间。

代理人员

选择代理的人员

范围

可以指定分派仅对当前网站有效，或对整个Site Collection或Server Farm有效。

请注意：长期任务代理只适用于首次分配的用户，如果任务是通过“转发工作流任务”流程节点或者“指定任务分派”的将不受“长期任务代理”的设定影响。


我的工作流任务Web控件

我的工作流任务Web控件

此Web控件显示当前用户相关的人机交互任务，如审批、审阅、数据收集等。

您需要在首页加入‘我的相关任务“Web控件。请点击”网站操作“，然后选择”编辑网页“子菜单项。

Web控件最佳显示位置在页面的左边，因此在左部区域，点击”添加Web控件“。

您可以在”杂项“组中找到”我的流程任务“.

选择此Web控件后，点击”添加“按钮后，Web控件被添加到首页。

Web控件默认显示：

  • 流程关联的项目名称.
  • 流程名称.
  • 目前状态.
  • 等待开始时间.
  • 相应的流程节点类型

点击”退出编辑模式“后，完成了Web控件的设置。

要编辑此Web控件的设定，可以点击”编辑“按钮。

此外，Web控件中显示的选项有：

  • 任务来源： 您可以选择当前网站的工作流或者是网站集的工作流。
  • 显示所有用户的任务：您可以选择是只显示当前用户或者选择所有用户的任务.
  • 发起人： 添加一列显示工作流的发起人.


我启动的工作流Web控件

我启动的工作流Web控件

此Web控件显示当前用户启动的工作流相关信息

您需要在首页加入‘我的相关任务“web控件。请点击”网站操作“，然后选择”编辑网页“子菜单项。

Web控件最佳显示位置在页面的左边，因此在左栏，点击”添加Web控件“。

您可以在”杂项“组中找到”我的相关工作流任务“.

选择此Web控件后，点击”添加“按钮后，Web控件被添加到首页。

Web控件默认显示：

  • 流程关联的项目名称.
  • 流程名称.
  • 流程启动时间.
  • 流程空闲时间，或已经结束的时间.
  • 当前流程状态（流程节点）：对应的超链接可以链接到该流程的状态监控图

点击”退出编辑模式“后，完成了Web控件的设置。

要编辑此Web控件的设定，可以点击”编辑“按钮。

此外，Web控件中显示的流程分为下列4类：

  • 运行中
  • 已经完成
  • 发生错误
  • 已经取消

通过这个Web控件，用户可以设置查看在当前网站中所启动的所有流程，或是当前网站集中的所有网站内启动的所有流程。


工作流计划

工作流计划

工作流计划可以对指定的列表项目定时触发工作流。

要配置一个项目的计划，您需要点击该项目，在菜单项中选择“工作流计划”。

如果还没有计划，您需要新建一个。在页面上点击“添加计划”按钮

选项

常规设置

从和当前列表关联的已发布的工作流列表中选择工作流名称（允许被手工触发的流程）。

计划开始

配置计划开始触发的时间。

循环设置

可以以小时、天或月为单位进行触发；可以指定仅在工作日运行，则系统将根据“企业日历”中设定的工作日，仅在工作日触发工作流

计划结束

可以指定固定日期为结束日，或触发次数限制或不限时间。

全部配置完毕后，点击“保存”按钮。

如果您要编辑计划，可以直接点击工作流计划名称的链接。


关于电子邮件审批

关于电子邮件审批

邮件审批功能可以通过普通pop3邮件进行审批时，系统发出电子邮件给用户，通知用户有工作流任务等待审批，并可在邮件中提示用户，可以直接通过回复电子邮件进行审批。用户可以回复电子邮件，在电子邮件中输入“同意”或“拒绝”分别代表同意或拒绝该审批任务。

此功能的更多信息，请查看管理邮件审批设置。

邮件审批功能可以和“要求审批” 和“收集数据”流程节点相结合运作。 在流程节点的配置界面里，流程设计人员需要选择‘允许邮件审批“的选项。而且请注意，邮件审批只能在”发送方式“选择为邮件时才有效。

当邮件审批功能被使用时，在电子邮件模板的页脚有补充说明来解释如何使用邮件审批。当系统接收到返回的邮件，它会扫描回复内容的前二十行作为识别邮件审批的内容。它可以扫描从电子邮件的顶部，并使用向下首个认可来看，它认为是一个公司准许整个单词或词组行全由自己完全匹配。公认的单词或词组，似乎与识别的同一行上的其他文字会造成的词或短语被忽略，并会被忽略。

如果匹配的短语没有找到，则有邮件会发送给用户告知他的回应没有被接受。用户可以再次用可识别的短语来回复此邮件使同意或拒绝生效。

请注意： 当带有邮件审批功能的邮件发出后，一段特征码将添加在邮件主题内，请不要编辑或删除此特征码。

可识别的短语可由系统管理员设定。更多信息请查看管理邮件审批设置。

例子如下；


流程节点

葡萄城吉流(FlowMan)
流程节点

关于“流程节点”的主题
4 项

Help and How-to
人机交互

Help and How-to
SharePoint列表和文档库操作

Help and How-to
流程逻辑

Help and How-to
流程操作


人机交互

人机交互

关于“人机交互”的主题
7 项

Help and How-to
发送通知

Help and How-to
要求审批

Help and How-to
收集数据

Help and How-to
要求审阅

Help and How-to
完成工作流任务

Help and How-to
委派工作流任务

Help and How-to
任务提醒


发送通知

发送通知

此流程节点可以通过电子邮件或手机短信等形式向参与工作流程中人机交互动作的用户发送通知信息。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

选项

收件人

设置将收到通知的人员的地址信息。您可以通过点击 [image] 打开人员选取器。

抄送人

设置通知抄送人员的地址信息。您可以通过点击 [image] 打开人员选取器。

发件人

设置通知的发件人信息，只能设置一人。您可以通过点击 [image] 打开人员选取器。

主题

输入通知的主题，可以添加动态引用 。

通知正文

富文本/纯文本

如果您选择富文本格式，则正文内容可以实现黑体，斜体等效果。纯文本只是简单的输入文本不带有字体格式。

通知内容

输入通知内容，您可以在正文中添加动态引用 。

递送形式

可以选择“电子邮件”或者用户定义的发送形式。


完成工作流任务

完成工作流任务

此流程节点可以自动完成指定的流程节点相关的所有未完成人机交互任务（审批、审阅、收集数据等）。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

选项

流程节点ID

您可以指定需要自动完成的流程节点ID，首先您需要在工作流变量中建立流程节点类型的变量。

延迟时间

指定在自动完成指定任务前需要延迟的时间，可以设定天数，小时数，分钟数。如果在等待中指定任务被手动完成了，则此流程节点也相应结束；如果指定的任务没有在延迟时间内完成，则此流程节点会根据设置完成指定任务。

延迟时间至少1分钟。

完成结果

指定完成结果：批准、拒绝、继续；其中批准和拒绝仅用于“要求审批”的任务，继续则用于其他人机交互任务。

发送“不再需要反馈”的通知

如果选中，则在被此流程节点自动完成指定任务后，会发送邮件通知指定任务的审批人，不再需要他进行操作。

注释

当指定任务被自动完成后，注释将针对和指定任务节点相关的每个任务添加。


委派工作流任务

委派工作流任务

此流程节点可以在设定的时间后，将指定的流程节点相关的任务转发到其他用户处。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

选项

节点ID

当配置一个审批或审阅任务时，您可以把它的节点ID保存至一个工作流变量中，在这里您就可以指定需要转发任务的节点ID

转发时间延迟

指定在转发和该任务节点相关的任务前的延迟时间。

转发给

指定转发任务的用户或用户组。

注释

转发任务时的注释，此内容会显示在工作流历史页面中。

应用于

所有未执行的任务将把所有还没有执行的任务转发。第一个未执行的任务将只转发第一个没有执行的任务，其他的任务将被置为不再要求。


要求审批

要求审批

此流程节点可以在流程中增加审批人员，审批人员需要进行批准拒绝的选择，并输入评论。更多实际流程运行操作请查看 同意、拒绝项目。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

在设计画面上加入了此流程节点后，将有2条分支。当设定的条件值结果为否时，流程将会执行左边的分支；当设定的条件值为是时，流程将会执行右边的分支。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看工作流设计器入门。

选项

选择审批人

可以选择多个SharePoint用户，SharePoint用户组，或企业组织结构里的角色，更多信息请查看选择人员和角色。

审批人中的SharePoint用户组可以作为一个审批人员对待，也即系统将为该用户组产生一条审批任务，并给用户组发送审批通知；或可以展开，将用户组中的每个人都作为一个审批用户对待。

审批代理设置

可以针对每个审批人（SharePoint用户、SharePoint用户组或角色）单独设定“允许代理”和“需要审批的通知/不需要审批的通知”。 允许代理意味着接受到该审批任务的审批人员可以在运行时将该审批任务分配给其他用户进行审批；反之则不允许。

允许代理

选择此项后，指定审批人员可以把任务委派给其他人员处理。更多信息请查看委派审批任务。

允许邮件审批

如果SharePoint已经成功配置，则您可以允许审批人员使用邮件审批。

通知设定

通知包括“需要审批的通知”和“不需要审批的通知”2种类型。分别代表在审批任务生成时发送给相应审批人员的通知和审批任务取消或完成时，发送给还没有进行审批操作的审批人员的通知。

发送方式

通知的发送方式可以选择：电子邮件，用户自定义方式，不发送3种类型。用户自定义方式可以查看用户设定。

请注意：GrapeCity不对因邮件，SMS系统引起的问题提供支持。

主题

默认为“需要审批/不再需要审批”，

富文本/纯文本

邮件格式的设定。如果您选择富文本，则可以对正文使用粗体，斜体，下划线等格式设定。

通知正文

输入通知邮件的具体文本，或可以添加 动态引用生成动态文本。

审批方式设定

有多名审批人员时，有五种审阅方式可供选择：

  • 并行审批：选择的审批人员必须全部批准，节点状态才置为批准；任何一个人拒绝则节点状态为拒绝；所有审批人员可以同时审批，没有先后顺序。
    • ?
  • 顺序审批：选择的审批人员必须全部批准，节点状态才置为批准；任何一个人拒绝则节点状态为拒绝；所有审批人员按照选择审批人员的顺序进行审批，前一个人审批完成后后一个人才能审批。
    • ?
  • 第一个审批：以第一个对审批任务作出反馈的人员的审批结果为标准，同意即节点同意，拒绝即节点拒绝。
    • ?
  • 任意人同意：选择的所有审批人员中任意人作出同意审批操作，则节点状态置为同意；所有审批人员均拒绝，节点状态置为拒绝。
    • ?
  • 权重（投票）：选择这个选项时，对每个审批人员，可以单独设定具有的票数，默认为每人一票；最后输入“通过需要的票数”，对节点进行同意的审批操作人员的票数之和达到或超过“通过需要的票数”后，该节点状态置为同意；否则为拒绝。

加签设定

在下列情况下，允许审批人员向前或向后增加一个或多个审批人：

  • 第一个审批
  • 顺序审批（包括仅有一个审批人，或仅有一个用户组但是没有展开的情形）

请注意：通过加签增加出来的一个或多个审批人，不允许再次加签，任意一个人进行了审批动作后，流程将向下执行。

下列情况下，允许审批人员在当前审批中增加一个或多个审批人员

  • 并行审批（多于一个审批人或用户组）
  • 任意人同意

内容类型选择

任务列表的内容类型选择：设计时可以选择人机交互任务对应的任务列表的内容类型。其中，任务列表是在“工作流选项”中设定的

任务名称

可以设定工作流任务名称，替代默认名称。

保存流程节点ID

流程节点在运行时对应一个唯一的标识ID，该ID可以保存在<流程节点ID>类型的工作流变量中，供其他流程节点调用。比如转发工作流任务 和 任务提醒 流程节点。


收集数据

收集数据

此流程节点给特定用户分配任务，用户需要通过提供特定的数据来完成该项任务。工作流将停止在该节点处直到用户提供了特定的数据，用户提供的数据在下面的流程中可以直接读取。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看工作流设计器入门.

选项

收集用户名

数据收集的任务分配的用户或用户组；仅能分配给一个用户或用户组；如果分配给用户组，则该组中第一个反馈的用户将作为该组的代表反馈数据。

内容类型

使用现有的或新建的Workflow Task列表作为收集数据的来源；

如果使用现有的，则从Workflow Task现有的内容类型中选择，还可以对现有内容类型包含的字段进行增加、修改和删除等操作。

字段列表

针对收集数据的内容类型的每个字段，都可以指定一个工作流变量存储收集到的数据

如果使用新建内容类型，则可以增加字段，包括字段的名称，数据类型，默认值和是否必须输入等选项。

收集数据的内容类型的各个字段属性可以在SharePoint内容类型设定中进一步设置；针对内容类型的各个字段的修改尽在工作流发布後才生效。

发布任务编辑表单

在使用已经存在的内容类型的情况下，工作流设计者可以通过这个选项决定在发布工作流的时候是否重新发布内容类型的编辑表单，覆盖原来的编辑表单；如果原来的编辑表单是客户化过的，则可以选择不重新发布任务编辑表单。

仅显示关联了工作流变量的字段

选择这个选项将在最终用户（数据收集对象）的工作流任务编辑画面中显示已经关联到某个工作流变量的字段；例如，在流程设计中设计了3个字段的内容类型，但仅将其中一个字段设定为保存到某个工作流变量，则最终用户的工作流任务编辑画面中仅显示一个字段。

任务描述

输入最终用户的工作流任务编辑画面中显示的任务表述；例如：“请输入下列信息”。

通知信息模板

包括通知用户输入数据和通知用户不需要再输入数据的通知信息模板。

允许代理

如果选择允许代理，则收到数据收集任务的用户可以将该任务转发给其他用户完成。

允许通过电子邮件反馈信息

最终用户可以通过直接答复邮件反馈需要他们提供的信息。

更多信息请查看邮件审批。

工作流任务名

以设定工作流任务名称，替代默认名称。

保存流程节点ID

可以将任务节点ID保存在工作流变量中，用于其他流程节点。


要求审阅

要求审阅

此流程节点可以要求一个或多个用户对流程进行审阅和评论操作。更多实际流程运行操作请查看 同意、拒绝项目。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

选项

审阅用户选择

可以选择多个SharePoint用户，SharePoint用户组，或企业组织结构里的角色，更多信息请查看选择人员和角色。

审批人中的SharePoint用户组可以作为一个审批人员对待，也即系统将为该用户组产生一条审批任务，并给用户组发送审批通知；或可以展开，将用户组中的每个人都作为一个审批用户对待。

编辑审阅用户设置

您可以统一设定所有审阅用户的设置，也可单独设定每一个审阅用户的设置。

允许代理

是否允许收到审阅任务的用户将任务转发给其他用户， 更多信息请查看委派审批任务。

通知信息模板

包括通知用户输入数据和通知用户不需要再输入数据的通知信息模板。

审阅选项

有多名审阅人员时，有两种审阅方式可供选择：

  • 并行审阅： 选择的审阅人员必须全部审阅，节点状态才置为通过；任何一个人没有审阅则节点状态为待定；所有审阅人员可以同时审阅，没有先后顺序
  • 第一个审阅： 以第一个对审阅任务作出反馈的人员的审批结果为标准，即节点通过。

任务名称

可以设定工作流任务名称，替代默认名称。

保存流程节点ID

可以将任务节点ID保存在工作流变量中，用于其他工作流任务，例如转发工作流任务 和 任务提醒流程节点。


任务提醒

任务提醒

此流程节点对到期仍未进行审批或审阅等人机交互操作的人员发送提醒信息。一般使用“执行并行操作”将任务提醒和要求审批的动作作为并行操作进行管理。

在上图中，您可以看到“要求审批”和“任务提醒”在一个并行操作下，当“要求审批”没有在等待时间内完成，则任务提醒就会发送通知给指定用户提醒完成该任务，提醒的次数根据配置而定。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门.

选项

流程节点ID

选择保存了需要进行提醒的那个节点的编号的工作流变量，以便确定需要向那些人员发送提醒信息（保存节点编号的工作流变量的值应在相应的审批或审阅等人机交互节点中设定）。

提醒次数

设定需要进行提醒的次数，每次提醒之间根据下面的提醒延迟时间设定，延迟一定的时间。

提醒延迟时间

设定提醒延迟的时间，也即两次提醒之间的延迟时间。

提醒主题

提醒信息的主题。

抄送

提醒信息抄送的人员。

提醒正文

富文本/纯文本

如果您选择富文本格式，则正文内容可以实现黑体，斜体等效果。纯文本只是简单的输入文本不带有字体格式。

通知内容

输入通知内容，您可以在正文中添加动态引用 。

递送形式

可以选择“电子邮件”或者用户定义的发送形式。


SharePoint操作

SharePoint操作

关于“SharePoint操作”的主题
17 项

Help and How-to
签入记录

Help and How-to
签出记录

Help and How-to
取消签出记录

Help and How-to
复制记录

Help and How-to
创建记录

Help and How-to
删除记录

Help and How-to
更新记录

Help and How-to
记录日志到历史列表

Help and How-to
查询列表

Help and How-to
设置审批状态

Help and How-to
设置字段值

Help and How-to
设置字段权限

Help and How-to
创建列表

Help and How-to
创建站点

Help and How-to
删除站点

Help and How-to
复制到指定目录

Help and How-to
复制到SharePoint


取消签出记录

取消签出记录

此流程节点可以在当前网站中取消一个已经签出的文档的“签出”状态。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

选项

列表

选择需要取消签出的文档库或表单库；如果当前列表是文档库或表单库，则默认选项为“当前项目”。

条件设置

如果需要取消签出的文档不是当前项目，则需要确定被取消签出的文档或表单范围

左边列表可以选择一个字段名，右边则可以直接输入值或者通过点击 SetValue 按钮 按钮， 在弹出的内容选取器窗口中选择其他列表或者工作流变量的值。


签入项目

激活葡萄城吉流（FlowMan）

此流程节点可以签入利用“签出项目”节点签出的文档库项目；如果选择的项目不是由“签出项目”签出的，则会产生运行错误。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

选项

列表

选择需要签入的文档库或表单库；如果当前列表是文档库或表单库，则默认选项为“当前项目”。

条件设置

如果需要签入的文档不是当前项目，则需要确定被签入的文档或表单范围

左边列表可以选择一个字段名，右边则可以直接输入值或者通过点击 SetValue按钮 按钮， 在弹出的内容选取器窗口中选择其他列表或者工作流变量的值。

签入类型

选择签入的版本：主版本，次版本，版本不变化。

注释

输入此次签入的说明。


签出项目

激活葡萄城吉流（FlowMan）

此流程节点可以签出当前网站里的文档库或图片库或表单库项目。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

选择需要签出的文档库或表单库；如果当前列表是文档库或表单库，则默认选项为“当前项目”。

条件设置

如果需要签出的文档不是当前项目，则需要确定被签出的文档或表单范围

左边列表可以选择一个字段名，右边则可以直接输入值或者通过点击 SetValue按钮 按钮， 在弹出的内容选取器窗口中选择其他列表或者工作流变量的值。


复制项目

激活葡萄城吉流（FlowMan）

此流程节点可以从当前站点的某个列表或文档库中拷贝一条记录到当前站点的另一个列表或文档库。指定的源和目标都必须是列表或文档库的根，不能是文档库的目录。源和目标的内容类型（Content Type）必须一致，否则拷贝时会产生错误信息。如果您需要拷贝文档库的目录（包括子目录）到SharePoint中的位置，可以使用“复制到SharePoint”流程节点。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

选项

源列表

选择需拷贝的记录所在的列表或文档库。

检索条件

如果需要拷贝的记录不是当前记录，则需要确定被拷贝的文档或表单范围

左边列表可以选择一个字段名，右边则可以直接输入值或者通过点击 SetValue按钮 按钮， 在弹出的内容选取器窗口中选择其他列表或者工作流变量的值。

目标列表

此必填字段是用来选择需要拷贝到的列表或文档库。

覆盖重复记录

如果目标列表中已经存在您需要拷贝的记录，则需要您在此选择是否覆盖已经存在记录。


复制到指定目录

复制到指定目录

此流程节点可以将当前记录关联的文档（仅适用于文档库、图片库或表单库）拷贝到指定的文件目录下。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看工作流设计器入门。

选项

The copy to fileshare form

指定目录

需要拷贝到的目标目录，可以是网络共享目录，如：\\fileshare\folder1，此目录必须是有效目录。

用户名

拥有访问指定目录权限用户的用户名。

密码

拥有访问指定目录权限用户的密码。

域

拥有访问指定目录权限用户的域。

也可从预先设定的证书类型的工作流常量中选择。


复制到SharePoint站点

复制到SharePoint站点

此流程节点可以将当前记录关联的文档（仅适用于文档库、图片库或表单库）。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

选项

The copy to SharePoint form

指定目录

选择或输入目标文档库、图片库或表单库的URL

覆盖已存在记录

选择拷贝时是否覆盖已经存在的同名内容。

创建目录结构

选择拷贝时是否创建和当前库中相同的目录结构。

目标服务器用户权限

输入在目标服务器有拷贝时需要的权限的用户名、密码

错误处理

详情请查看 错误处理。


创建记录

创建记录

此流程节点可以在当前站点中的指定列表中创建记录。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

选项

创建记录的列表

此必填字段用来选择需要创建记录的列表。

内容类型

根据选择的列表，选择该列表中已经存在的内容类型。

覆盖已经存在的记录

选择拷贝时是否覆盖已经存在的同名内容。如果您选择不覆盖但目标列表有同名的记录，则If you would like to overwrite an existing item in the destination document library tick this check box. If you do not chose to overwrite an item, 则一个标示符会被追加至文件名上（仅适用于文档库）。

保存新的记录

选择工作流变量保存新创建的记录ID

字段列表

首先需要选择一个字段名，然后可以直接输入值或者通过点击右边的 SetValue按钮 按钮， 在弹出的内容选取器窗口中选择其他列表或者工作流变量的值。最后点击“保存”按钮，至此一个更新的字段被添加至字段列表中。

您可以同时添加多个更新字段。

如果需要更改已经添加的字段，您可以在字段列表中选择它，则您可以更改或点击“删除”按钮删除它。

字段后带*的为必填字段，您必须为它设定一个值，否则会创建记录失败。


创建站点

创建站点

此流程节点可以在工作流所属站点集中的任意位置创建一个新站点。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

选项

站点标题

输入创建站点的标题，您也可以点击 1 添加动态引用。

站点描述

输入创建列表的描述，您也可以点击 1 添加动态引用。

继承权限

是否继承自父站点的权限。

如果选择不继承，则站点所有人必须被指定，您可以从人员选取器中找到或输入新站点的所有人

父站点

可以选择当前SharePoint顶级站点或其下的任意子站点作为要新建站点的父站点，或直接输入父站点的URL。

URL

输入需新建站点的相对URL；例如，您需要建立的站点地址为http://parentsite/test1， 父站点已经选择了http://parentsite， 则在此只需输入“test1”。

上述父站点或需新建的子站点相对URL均可利用动态引用生成。

站点模板

选择站点模板，如果当前SharePoint环境里有多语言包，则先选择语言後在选择相应语言的模板。

SharePoint模板的信息,请查看相关SharePoint帮助文档。

使用父站点的导航设置

指定是否使用父站点的导航栏。

保存URL

指定工作流变量保存最终新建的站点的URL。


创建列表

创建列表

此流程节点可以在当前网站所在的网站集下的任意网站中创建列表。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

选项

列表名称

输入创建列表的名称，您也可以点击 1 添加动态引用。

列表描述

输入创建列表的描述，您也可以点击 1 添加动态引用。

列表模板

根据所选择的列表所属网站，列出该网站中的所有列表模板类型供选择。

列表所属网站

可以从当前网站集的树状结构中选择；或直接输入网站URL。


删除记录

删除记录

此流程节点可以在当前站点中的指定列表中删除记录。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

选项

列表

选择需要删除的文档库或表单库；默认选项为“当前记录”。

条件设置

如果需要删除的记录不是当前记录，则需要确定被删除的文档或表单范围

左边列表可以选择一个字段名，右边则可以直接输入值或者通过点击 SetValue按钮 按钮， 在弹出的内容选取器窗口中选择其他列表或者工作流变量的值。


删除站点

删除站点

此流程节点可以在当前的SharePoint环境中删除指定的站点。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

选项

父站点

可以选择当前SharePoint顶级站点或其下的任意子站点作为要删除站点的父站点，或直接输入父站点的URL。

URL

输入需删除站点的相对URL；例如，父站点为选择为http://parentsite ，需要删除的站点URL为http://parentsite/site1 ，则最终需要输入的是“site1”。

上述父站点或需新建的子站点相对URL均可利用动态引用生成。


记录日志到历史信息

记录日志到历史信息

此流程节点可以将用户自定义信息记录进入工作流日志里的“工作流信息部分”。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门.

选项

输入需要在工作流日志中记录的内容，您也可以点击 1 添加动态引用。


查询列表

查询列表

此流程节点可以检索SharePoint列表中的值并保存在指定的工作流变量中。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门.

选项

编辑模式

选择是否使用检索生成器来检索列表，或者在CAML编辑器中直接对CAML进行编辑，生成复杂的跨列表的CAML检索语句。

在检索生成器模式下，有下列选项可设置。您可以随时切换到CAML编辑器模式下查看CAML。

列表

选择需要检索的列表。

字段

选择需要检索的列表中的字段。

过滤

显示列表中所有内容，或对一个或多个字段设定过滤条件。

排序

对一个或多个字段进行排序。

保存结果

检索结果可保存在指定的工作流变量里；如果指定的工作流变量是集合变量，则所有结果都可以保存；否则仅保存检索到的第一个值；如果检索结果是多列，则仅保存第一列的值。


设置审批状态

设置审批状态

此流程节点可以设置相应的SharePoint项目的内置SharePoint审批状态。对需要设定审批状态的列表，必须将其“审批状态”设置为是。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看工作流设计器入门。

选项

设置状态

选择审批状态，可供选择的有“批准”，“拒绝”，“待定”，“草稿”，“计划”

注释

输入审批状态的注释。您可以添加动态引用 。

列表设置

要使这个流程节点可以工作正常，必须在“列表设置”中选择“版本控制设置”，把“审批状态”设置为是。


设定字段值

设定字段值

此流程节点可以设定当前流程相关的列表项目的值。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

选项

设定

左边列表可以选择一个字段名，右边则可以直接输入值或者通过点击 SetValue按钮 按钮， 在弹出的内容选取器窗口中选择其他列表或者工作流变量的值。

直到文档可用

仅适用于文档库。如果工作流试图更新的项目是一个被用户签出的文档，则工作流会失败。选择这个选项后，工作流会等待直到文档被签入后才继续运行。


设定记录权限

设定记录权限

此流程节点可以设置当前项目的用户使用权限。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门.

选项

从列表继承权限

设定是否从项目所属的列表继承权限，默认为是，也即项目的权限和列表权限一致；如果选择否，则显示设置权限的属性

去除已存在权限

设定在设置权限时是否去除已经存在于该项目上的权限属性。

用户（组）

可选择打算对之进行授权的用户或用户组。

权限

在权限下拉框中选择您需要赋给选择用户的权限，如果删除它的权限，可以选择“移除”。

选择完“用户（组）”和“权限”后，点击保存，则会在更新列表中增加一行

如果您要编辑已添加的内容，则在更新列表中选择该行，编辑完毕后，点击“保存”

如果您要删除已添加的内容，则在更新列表中选择该行，点击“删除”按钮。

请注意：如果流程发起人没有该项目的读权限，则工作流可能会运行失败，因为工作流要求运行的用户对该项目至少有读权限。


更新记录

更新记录

此流程节点可以指定当前网站内的列表，设定列表的一个或多个字段值。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

选项

更新字段

您首选选择需要更新的字段，默认为“当前项目”

如果需要更新的不是当前项目，则需要确定被更新的文档或表单范围

左边列表可以选择一个字段名，右边则可以直接输入值或者通过点击 SetValue按钮 按钮， 在弹出的内容选取器窗口中选择其他列表或者工作流变量的值。

在确定了更新的项目后，再设置具体需要更新的字段，在选择框中选择更新字段后，会有窗口弹出

在弹出框中输入更新的值，您也可通过点击 SetValue按钮 按钮， 在弹出的内容选取器窗口中选择其他列表或者工作流变量的值。

点击保存后，会在更新列表中添加一行

如果您需要更改更新的字段名或值，则直接在更新列表中选中该行，点击“编辑”按钮，则会有编辑窗口弹出，您更新完毕后点击“保存”按钮即可

如果您需要删除更新的字段，则直接在更新列表中选中该行，点击“删除”按钮。

等待直到文档可用

仅适用于文档库。如果工作流试图更新的项目是一个被用户签出的文档，则工作流会失败。选择这个选项后，工作流会等待直到文档被签入后才继续运行。


流程逻辑

流程逻辑

关于“流程逻辑”的主题
10 项

Help and How-to
过滤

Help and How-to
逐条执行

Help and How-to
循环

Help and How-to
如果..就执行

Help and How-to
并行执行

Help and How-to
条件设置

Help and How-to
状态机

Help and How-to
改变状态

Help and How-to
跳转

Help and How-to
跳转+


改变状态

改变状态

此流程节点可以选择状态机迁移的下一个状态，或结束当前的状态机。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

注意此流程节点只能被添加于“状态机”内部中。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

选项

选择下一个状态

选择下一个需要运行的状态。

选择“结束状态机”则将退出当前状态机的运行。


过滤器

过滤器

此流程节点可以根据设定的条件计算结果判断流程分支是否继续执行下去。如果条件为真则继续执行。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

The condition form

更多信息请查看 “条件设置”流程节点。


逐条执行

逐条执行

此流程节点可以对指定的集合变量进行遍历，逐个将每个集合变量的值赋予一个工作流变量，并传递给包含在逐个执行节点内的其他流程节点。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门.

选项

目标集合型变量

指定需要遍历的集合变量

保存结果

存储当前遍历到的集合变量值的工作流变量。

可以选择任何类型的工作流变量，设计人员需要确定此变量的类型与得到的结果类型一致。

索引

存储当前遍历到的集合变量序号，第一个变量的从0开始。


跳转

跳转

此流程节点可以对可以在工作流中根据您事先设定的条件把工作流路径跳转到您指定的流程节点处（只能在同级中跳转）

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门.

选项

跳转分支

您可以添加，编辑，删除不同的设置，以此设定流程节点跳转到不同的目的节点。

你首先需要指定目的流程节点，可输入描述，必须设定此跳转的一个触发条件。

跳转条件

您可以为此条件设定单一条件或组合条件，一旦工作流运行到时根据此条件确定是否触发跳转，或跳转到何目的流程节点。

设定的条件信息，请查看 “条件设置” 流程节点。

设定完毕后，在设计画面上会用虚线表示，如下图。


跳转+

跳转+

此流程节点可以对可以在工作流中根据您事先设定的条件把工作流路径跳转到您指定的流程节点处（只能在同级中跳转）

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门.

选项

跳转分支

您可以添加，编辑，删除不同的设置，以此设定流程节点跳转到不同的目的节点。

你首先需要指定目的流程节点，可输入描述，必须设定此跳转的一个触发条件。

跳转条件

您可以为此条件设定单一条件或组合条件，一旦工作流运行到时根据此条件确定是否触发跳转，或跳转到何目的流程节点。

设定的条件信息，请查看 “条件设置” 流程节点。

设定完毕后，在设计画面上会用虚线表示跳转路径，您也可以在分支上添加其他节点，这些节点会在跳转前被执行，如下图。


循环

循环

此流程节点内部可以包含其他的流程节点操作，当循环内设定的逻辑判断条件结果为真时，重复执行节点内部包含的流程节点操作。循环之间的延迟时间可以设定。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

The condition form

更多信息请查看 “条件设置” 流程节点。


并行操作

并行操作

此流程节点可以并行执行2个或以上的工作流任务，直到所有并行任务都完成才继续向下执行。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

选项

The condition form

分支

您可以点击“添加”新增一个分支，或者点击每个分支后的“删除”按钮来删除此分支。单击分支名称可以更改名称。


如果..就执行

如果..就执行

此流程节点如果满足设定的条件，则执行节点中包含的其他流程节点组合。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

The condition form

更多信息请查看 ”条件设置“ 流程节点。


条件设置

条件设置

此流程节点可以根据设定的条件值的结果决定执行两个分支之一

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

在设计画面上加入了此流程节点后，将有2条分支。当设定的条件值结果为否时，流程将会执行左边的分支；当设定的条件值为是时，流程将会执行右边的分支。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

条件类型

一共有九种条件类型可以选择：

比较当前列表项

Compare field form

您可以用此条件判断当前项目的指定字段值与设定条件是否一致，您可以使用内容选取器 设定值。

比较任何数据源

Compare any data source form

您可以用此条件判断网站内任何列表内的项目值是否与设定一致，您可以使用内容选取器 设定值。

标题字段包含

The title field contains keywords form

您可以用此条件判断项目标题是否包含有设定的值，您可以使用内容选取器 设定值。

更新时间段

The modified in a specific date span form

您可以用此条件判断项目的更新时间是否在设定的时间区域内，您可以使用内容选取器 设定值。

更新人员

The modified by a specific person form

您可以用此条件判断项目的更新人员是否是选择的人员，您可以使用内容选取器 设定值。

创建时间段

您可以用此条件判断项目的创建时间是否在设定的时间区域内，您可以使用内容选取器 设定值。

创建人员

您可以用此条件判断项目的创建人员是否是选择的人员，您可以使用内容选取器 设定值。

文件类型

The file type condition form

当前项目是文档时，可以用此条件判断文档的大小是否是设定的类型，您可以使用内容选取器 设定值。

文件大小

The file size is a in a specific range form

当前项目是文档时，可以用此条件判断文档的大小是否在设定的区域中，您可以使用内容选取器 设定值。

多条件组合

所有设定的条件都显示在条件列表中，您可以使用”添加“按钮增加一个新的条件，并且在条件设定窗口中选择联接方式，保存的条件会显示在条件列表中。

如果您需要编辑条件，可以在条件列表中选中该条，点击“编辑”按钮，在弹出的编辑窗口中进行编辑。

如果您需要删除条件，可以在条件列表中选中该条，点击“删除”按钮。

And Or Conditions


状态机

状态机

此流程节点可以定义多个状态，它的子节点可以在不同的状态之间流转，直到状态转变为“结束状态”。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门.

选项

初始状态

选择一个工作流运行时第一个到达的状态。

状态

状态机支持设置多状态。您可以添加编辑删除状态。

状态机在子节点上添加“改变状态”来使内部运转，这样在执行了一个状态下的子节点后可以流转到下一个状态。您也可以在状态机内部实现回转。

下面是一个使用“状态机”和“改变状态”的例子。


流程操作

流程操作

关于“流程操作”的主题
11 项

Help and How-to
创建动态字符串

Help and How-to
计算日期

Help and How-to
集合变量操作

Help and How-to
延迟一段时间

Help and How-to
延迟到

Help and How-to
结束工作流

Help and How-to
数学计算

Help and How-to
正则表达式

Help and How-to
设置变量值

Help and How-to
执行自定义代码

Help and How-to
等待记录被更新


创建动态字符串

创建动态字符串

“创建动态字符串”流程节点可以在工作流运行时执行基本的字符串连接，且可以把结果用于其他流程节点中。 使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。 需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情可查看工作流设计器入门。

选项

创建字符串

您可以使用动态引用把实时运行时工作流的变量属性连接成字符串。

存储结果

创建后的字符串结果会存储于您选择的工作流变量中。


计算日期

计算日期

此流程节点可以从指定日期时间中减去或增加一定的日期时间后产生新的日期时间。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。 详情可查看工作流设计器入门。

选项

日期

可以是指定的日期，当时的日期，或根据动态引用生成的日期。

时间

增加或减少的年、月、日、小时、分钟。

存储结果

计算后的结果存储于一个指定的日期类型工作流变量中。


集合变量操作

集合变量操作

此流程节点可以访问或操作集合型变量。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

选项

目标集合变量是每一个操作都需要选择的。

加

给目标集合变量的指定索引位置后增加一个变量值；如果没有指定索引值，则变量值将会加在目标集合变量的最后；如果指定的索引值大于目标集合变量的大小，则工作流则会出错。

移除

从目标集合变量里移除指定索引上的值，原来排在被移除索引后面的值的索引自动减一。

计数

统计目标集合变量包含的值的数量，并将结果保存在指定的工作流变量里。

获取值

从目标集合变量指定的索引上取值，并保存在指定的工作流变量里，变量类型要与目标集合变量的类型一致。

判断存在

判断目标集合变量里是否存在指定的值，判断结果保存在指定的布尔型工作流变量里。

排序

将现有的目标集合变量里的值按照升序或降序重新排列后保存到指定的集合变量里。

弹出值

从目标集合变量尾部提取值并保存到指定的工作流变量里，然后从目标集合变量中删除该值。

联和值

将目标集合变量里的所有值生成一个字符串存储到指定的工作流变量里，中间以指定的分隔符区分。


延迟一段时间

延迟一段时间

此流程节点可以指定工作流流程需要延迟的时间。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。 详情可查看工作流设计器入门。

选项

延迟时间

默认延迟时间为5分钟

您可以指定延迟的年、月、日、小时、分钟，也可以通过动态引用 来指定值。

仅计算工作时间

可以选择延迟时间仅计算工作时间，则非工作时间将在倒计时时被忽略。


延迟到

延迟到

此流程节点可以将流程停止在当前节点，直至设定的日期和时间。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

您可以使用下面3种方法来设定值

  • 使用您所在地区的时间格式（比如 年-月-日） 输入日期，在下拉框中选择时间。
  • 使用 [image] 来选择日期，在下拉框中选择时间。
  • 使用内容选取器选择其他列表或者工作流变量的值。


结束工作流

结束工作流

此流程节点可以结束当前工作流，并在工作流历史记录里写入日志信息。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

选项

The modified in a specific date span form

记录到历史列表的信息

输入结束当前工作流时向工作流日志里写入的内容

需要知道更多关于SharePoint历史列表的信息，请查看相关SharePoint帮助文档。


执行自定义代码

执行自定义代码

此流程节点可以执行自定义的代码，包括。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

选项

代码语言

您可以使用C#或者VB来编写自定义代码

代码类型

您可以编写自定义方法或者自定义类

引用Assembly

指定引用的Assembly文件地址

使用的命名空间

指定使用到的命名空间名称

正文

在此输入代码的正文，您也可以点击 1 添加动态引用。


数学计算

数学计算

此流程节点可以对两个数值进行加减乘除余的基本数学计算。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

操作数

输入或选择进行数学运算的2个数值

操作符

选择数学运算符号：加减乘除余

保存结果

选择保存计算结果的数字型工作流变量。


正则表达式

此流程节点可以对指定字符串运用正则表达式替换特定字符内容或检查字符串是否符合正则表达式设定的规则。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门.

选项

正则表达式

将对字符串运用的正则表达式。

操作类型

替换

用“替换文本”替换“输入文本”中符合正则表达式的文本。

检查符合性

利用正则表达式检查“输入文本”的符合性，结果为“是/否”。

分割

利用正则表达式分割“输入文本”，结果为包含分割结果的集合类型变量。

提取

检索“输入文本”，提取符合正则表达式的文本，保存在集合类型变量中。

替换文本

将用于替换符合正则表达式的文本。

输入文本

运用正则表达式的文本。

保存结果

存储利用正则表达式进行操作或比较的结果变量。


设置变量值

设置变量值

此流程节点可以为工作流变量。

请注意：要使用此流程节点必须先建立至少一个工作流变量供使用。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看工作流设计器入门.

选项

变量

您可以选择一个已经设定的工作流变量。

设值

您可以直接输入一个与变量类型相符合的值或者通过点击 SetValue按钮 按钮， 在弹出的内容选取器窗口中选择其他列表或者工作流变量的值。


等待记录被更新

等待记录被更新

此流程节点可以使当前工作流被暂停，直到当前流程对应的项目的某个字段被修改符合特定的条件。

使用此流程节点，您可以从左边的工具栏中拖拽出节点到设计画面的流程图线上，或者您可以先选中需要放置流程节点的流程图线，然后在左边的工具箱中双击流程节点，或者您可以右键点击需要放置的流程图线上，在出现的菜单中选择需要插入的流程节点。

需要配置此流程节点，您可以单击设计画面上此流程节点左上角的图形图标，或者鼠标右键点击此流程节点，选择“配置”来打开配置页面。详情请查看 工作流设计器入门。

选项

The wait for item update config form

等待的字段

选择当前列表中的某个字段

检索条件

检索条件包括"等于“，”不等于“，”大于“等比较符。比较的值您可直接输入或者通过点击 SetValue 按钮 按钮，在弹出的内容选取器窗口中选择其他列表或者工作流变量的值。


图形查看器Web控件

图形查看器Web控件

* 此功能只在葡萄城吉流（FlowMan）企业版中提供。

使用葡萄城吉流图形查看器Web控件可以用图形化的方式表现葡萄城吉流（FlowMan）报表。

To use the web part, it must be added to the home page of a site. Navigate to the home page of the site to which you want to add the web part then click "Site Actions" then "Edit Page".

The web part is best added to the left zone of the page so that the columns it contains have sufficient space to display 项. In the left zone, click the link "Add a Web Part", then select the GrapeCity Graph Viewer web part.

If you would like to use the web part with its default settings, then click "Exit Edit Mode".

To edit the default settings for the web part, click the "Edit" button then "Modify Shared Web Part".

A series of options will be shown in the tool pane to the right of the page that are specific to this web part.

Report to display

Select the chart to display from the drop down list.
Note this list is configurable by your system administrator via Central Admin.

Configuration

Chart Display Settings

Click on the Configure display settings link to set the chart type, size, colors, and other settings.

Columns Used in the Chart Display

Click on the Configure Columns used link to select which columns are shown in the chart. By default, all columns are included.

Chart Filters

Click on the Configure Filter Values link to set filter values for the report.
Note that not all report accept filter values.


报表查看器Web控件

报表查看器Web控件

* 此功能只在葡萄城吉流（FlowMan）企业版中提供。

Use the GrapeCity Report Viewer web part to display a 葡萄城吉流（FlowMan） report in tabular view.

To use the web part, it must be added to the home page of a site. Navigate to the home page of the site to which you want to add the web part then click "Site Actions" then "Edit Page".

The web part is best added to the left zone of the page so that the columns it contains have sufficient space to display 项. In the left zone, click the link "Add a Web Part", then select the GrapeCity Report Viewer web part.

If you would like to use the web part with its default settings, then click "Exit Edit Mode".

To edit the default settings for the web part, click the "Edit" button then "Modify Shared Web Part".

A series of options will be shown in the tool pane to the right of the page that are specific to this web part.

Report to display

Select the report to display from the drop down list.
Note this list is configurable by your system administrator via Central Admin.
Click the Show Filter checkbox to allow users to specify filter values

Records displayed per page

Enter a number to specify how many records should be displayed per page. Leave this setting blank to display all records on the one page.

Configuration

Filter

Click on the Configure Filter Values link to set filter values for the report.
Note that not all reports accept filter values.